USN-2569-1: Apport vulnerability

Ubuntu Security Notice USN-2569-1

14th April, 2015

apport vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.10
  • Ubuntu 14.04 LTS

Summary

Apport could be tricked into running programs as an administrator.

Software description

  • apport - automatically generate crash reports for debugging

Details

St├ęphane Graber and Tavis Ormandy independently discovered that Apport
incorrectly handled the crash reporting feature. A local attacker could use
this issue to gain elevated privileges.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 14.10:
apport 2.14.7-0ubuntu8.3
Ubuntu 14.04 LTS:
apport 2.14.1-0ubuntu3.9

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2015-1318