USN-783-1: eCryptfs vulnerability

Ubuntu Security Notice USN-783-1

8th June, 2009

ecryptfs-utils vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.04

Software description

  • ecryptfs-utils

Details

Chris Jones discovered that the eCryptfs support utilities would
report the mount passphrase into installation logs when an eCryptfs
home directory was selected during Ubuntu installation. The logs are
only readable by the root user, but this still left the mount passphrase
unencrypted on disk, potentially leading to a loss of privacy.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 9.04:
ecryptfs-utils 73-0ubuntu6.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

CVE-2009-1296