USN-417-2: PostgreSQL 8.1 regression

Ubuntu Security Notice USN-417-2

6th February, 2007

postgresql-8.1 regression

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Details

USN-417-1 fixed several vulnerabilities in the PostgreSQL server.
Unfortunately this update had a regression that caused some valid
queries to be aborted with a type error. This update corrects that
problem.

We apologize for the inconvenience.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 6.10:
postgresql-8.1 8.1.4-7ubuntu0.3
Ubuntu 6.06 LTS:
postgresql-8.1 8.1.4-0ubuntu1.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

LP: 83505