USN-2322-1: OpenStack Glance vulnerability

Ubuntu Security Notice USN-2322-1

21st August, 2014

glance vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 LTS

Summary

OpenStack Glance could be made to stop serving requests.

Software description

  • glance - OpenStack Image Registry and Delivery Service

Details

Thomas Leaman and Stuart McLaren discovered that OpenStack Glance did not
properly honor the image_size_cap configuration option. A remote
authenticated attacker could exploit this to cause a denial of service via
disk consumption.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 14.04 LTS:
glance-common 1:2014.1.2-0ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2014-5356