USN-2311-2: OpenStack Ceilometer vulnerability

Ubuntu Security Notice USN-2311-2

21st August, 2014

ceilometer vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 LTS

Summary

OpenStack Ceilometer could be made to expose sensitive information.

Software description

  • ceilometer - OpenStack Telemetry service

Details

USN-2311-1 fixed vulnerabilities in pyCADF. This update provides the
corresponding updates for OpenStack Ceilometer.

Original advisory details:

Zhi Kun Liu discovered that pyCADF incorrectly filtered certain tokens.
An attacker could possibly use this issue to obtain authentication tokens
used in REST requests.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 14.04 LTS:
ceilometer-common 2014.1.2-0ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2014-4615