USN-2300-1: LZO vulnerability

Ubuntu Security Notice USN-2300-1

24th July, 2014

lzo2 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS

Summary

LZO could be made to crash or run programs if it processed specially crafted data.

Software description

  • lzo2 - data compression library

Details

Don A. Bailey discovered that LZO incorrectly handled certain input data.
An attacker could use this issue to cause LZO to crash, resulting in a
denial of service, or possibly execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 14.04 LTS:
liblzo2-2 2.06-1.2ubuntu1.1
Ubuntu 12.04 LTS:
liblzo2-2 2.06-1ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2014-4607