USN-2291-1: MySQL vulnerabilities

Ubuntu Security Notice USN-2291-1

17th July, 2014

mysql-5.5 vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS

Summary

Several security issues were fixed in MySQL.

Software description

  • mysql-5.5 - MySQL database

Details

Multiple security issues were discovered in MySQL and this update includes
a new upstream MySQL version to fix these issues. MySQL has been updated to
5.5.38.

In addition to security fixes, the updated packages contain bug fixes,
new features, and possibly incompatible changes.

Please see the following for more information:
http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-38.html
http://www.oracle.com/technetwork/topics/security/cpujul2014-1972956.html

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 14.04 LTS:
mysql-server-5.5 5.5.38-0ubuntu0.14.04.1
Ubuntu 12.04 LTS:
mysql-server-5.5 5.5.38-0ubuntu0.12.04.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2014-2494, CVE-2014-4207, CVE-2014-4258, CVE-2014-4260