USN-2280-1: MiniUPnPc vulnerability

Ubuntu Security Notice USN-2280-1

16th July, 2014

miniupnpc vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 LTS
  • Ubuntu 13.10
  • Ubuntu 12.04 LTS

Summary

MiniUPnPc could be made to crash if it received specially crafted network traffic.

Software description

  • miniupnpc - UPnP IGD client lightweight library client

Details

It was discovered that MiniUPnPc incorrectly handled certain buffer
lengths. A remote attacker could possibly use this issue to cause
applications using MiniUPnPc to crash, resulting in a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 14.04 LTS:
libminiupnpc8 1.6-3ubuntu2.14.04.1
Ubuntu 13.10:
libminiupnpc8 1.6-3ubuntu2.13.10.1
Ubuntu 12.04 LTS:
libminiupnpc8 1.6-3ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart your session to make all
the necessary changes.

References

CVE-2014-3985