USN-2217-1: lxml vulnerability

Ubuntu Security Notice USN-2217-1

21st May, 2014

lxml vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 LTS
  • Ubuntu 13.10
  • Ubuntu 12.04 LTS

Summary

lxml could allow cross-site scripting (XSS) attacks.

Software description

  • lxml - pythonic binding for the libxml2 and libxslt libraries

Details

It was discovered that the lxml.html.clean module incorrectly stripped
control characters. An attacked could potentially exploit this to conduct
cross-site scripting (XSS) attacks.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 14.04 LTS:
python3-lxml 3.3.3-1ubuntu0.1
python-lxml 3.3.3-1ubuntu0.1
Ubuntu 13.10:
python3-lxml 3.2.0-1ubuntu0.1
python-lxml 3.2.0-1ubuntu0.1
Ubuntu 12.04 LTS:
python3-lxml 2.3.2-1ubuntu0.2
python-lxml 2.3.2-1ubuntu0.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make
all the necessary changes.

References

CVE-2014-3146