USN-2104-1: LXC vulnerability

Ubuntu Security Notice USN-2104-1

12th February, 2014

lxc vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.10

Summary

LXC would allow unintended access to the host, bypassing intended confinement.

Software description

  • lxc - Linux Containers userspace tools

Details

Florian Sagar discovered that the LXC sshd template set incorrect mount
permissions. An attacker could possibly use this flaw to cause privilege
escalation on the host.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 13.10:
lxc-templates 1.0.0~alpha1-0ubuntu14.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to recreate LXC containers created
with the sshd template to make all the necessary changes.

References

CVE-2013-6441