USN-2047-1: pixman vulnerability

Ubuntu Security Notice USN-2047-1

3rd December, 2013

pixman vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.10
  • Ubuntu 13.04
  • Ubuntu 12.10
  • Ubuntu 12.04 LTS

Summary

pixman could be made to crash if it opened a specially crafted file.

Software description

  • pixman - pixel-manipulation library for X and cairo

Details

Bryan Quigley discovered an integer underflow in pixman. If a user were
tricked into opening a specially crafted file, an attacker could cause a
denial of service via application crash.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 13.10:
libpixman-1-0 0.30.2-1ubuntu0.1
Ubuntu 13.04:
libpixman-1-0 0.28.2-0ubuntu1.1
Ubuntu 12.10:
libpixman-1-0 0.26.0-3ubuntu0.1
Ubuntu 12.04 LTS:
libpixman-1-0 0.24.4-1ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart your session to make
all the necessary changes.

References

LP: 1197921