USN-1859-1: libxi vulnerabilities

Ubuntu Security Notice USN-1859-1

5th June, 2013

libxi vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.04
  • Ubuntu 12.10
  • Ubuntu 12.04 LTS
  • Ubuntu 10.04 LTS


Several security issues were fixed in libxi.

Software description

  • libxi - X11 Input extension library


Ilja van Sprundel discovered multiple security issues in various
libraries and components. An attacker could use these issues to cause
applications to crash, resulting in a denial of service, or possibly
execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 13.04:
libxi6 2:
Ubuntu 12.10:
libxi6 2:1.6.1-1ubuntu0.1
Ubuntu 12.04 LTS:
libxi6 2:1.6.0-0ubuntu2.1
Ubuntu 10.04 LTS:
libxi6 2:1.3-3ubuntu0.2

To update your system, please follow these instructions:

After a standard system update you need to restart your session to make all
the necessary changes.


CVE-2013-1984, CVE-2013-1995, CVE-2013-1998