USN-1576-1: DBus vulnerability

Ubuntu Security Notice USN-1576-1

20th September, 2012

dbus vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.04 LTS
  • Ubuntu 11.10
  • Ubuntu 11.04
  • Ubuntu 10.04 LTS
  • Ubuntu 8.04 LTS

Summary

DBus could be made to run programs as an administrator.

Software description

  • dbus - simple interprocess messaging system

Details

Sebastian Krahmer discovered that DBus incorrectly handled environment
variables when running with elevated privileges. A local attacker could
possibly exploit this flaw with a setuid binary and gain root privileges.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 12.04 LTS:
dbus 1.4.18-1ubuntu1.1
libdbus-1-3 1.4.18-1ubuntu1.1
Ubuntu 11.10:
dbus 1.4.14-1ubuntu1.1
libdbus-1-3 1.4.14-1ubuntu1.1
Ubuntu 11.04:
dbus 1.4.6-1ubuntu6.2
libdbus-1-3 1.4.6-1ubuntu6.2
Ubuntu 10.04 LTS:
dbus 1.2.16-2ubuntu4.5
libdbus-1-3 1.2.16-2ubuntu4.5
Ubuntu 8.04 LTS:
dbus 1.1.20-1ubuntu3.7
libdbus-1-3 1.1.20-1ubuntu3.7

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2012-3524