USN-1708-1: libvirt vulnerabilities

Ubuntu Security Notice USN-1708-1

29th January, 2013

libvirt vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.10
  • Ubuntu 12.04 LTS

Summary

libvirt could be made to crash or run programs if it received specially crafted network traffic.

Software description

  • libvirt - Libvirt virtualization toolkit

Details

Wenlong Huang discovered that libvirt incorrectly handled certain RPC
calls. A remote attacker could exploit this and cause libvirt to crash,
resulting in a denial of service. This issue only affected Ubuntu 12.04
LTS. (CVE-2012-4423)

Tingting Zheng discovered that libvirt incorrectly handled cleanup under
certain error conditions. A remote attacker could exploit this and cause
libvirt to crash, resulting in a denial of service, or possibly execute
arbitrary code. (CVE-2013-0170)

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 12.10:
libvirt0 0.9.13-0ubuntu12.2
libvirt-bin 0.9.13-0ubuntu12.2
Ubuntu 12.04 LTS:
libvirt0 0.9.8-2ubuntu17.7
libvirt-bin 0.9.8-2ubuntu17.7

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make
all the necessary changes.

References

CVE-2012-4423, CVE-2013-0170