USN-1004-1: Django vulnerability

Ubuntu Security Notice USN-1004-1

13th October, 2010

python-django vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.10

Summary

Django could be made to insert arbitrary content into web forms.

Software description

  • python-django - High-level Python web development framework

Details

It was discovered that Django did not properly sanitize the cookie value
when applying CSRF protections resulting in a cross-site scripting (XSS)
vulnerability. With cross-site scripting vulnerabilities, if a user were
tricked into viewing server output during a crafted server request, a
remote attacker could exploit this to modify the contents, or steal
confidential data, within the same domain.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 10.10:
python-django 1.2.3-1ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2010-3082