USN-3298-1: MiniUPnP vulnerability

Ubuntu Security Notice USN-3298-1

24th May, 2017

miniupnpc vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 16.10
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

MiniUPnP could be made to crash or run programs if it received specially crafted network traffic.

Software description

  • miniupnpc - UPnP IGD client lightweight library

Details

It was discovered that MiniUPnP incorrectly handled memory. A remote
attacker could use this issue to cause a denial of service or possibly
execute arbitrary code with privileges of the user running an application
that uses the MiniUPnP library.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 16.10:
libminiupnpc10 1.9.20140610-2ubuntu2.16.10.1
Ubuntu 16.04 LTS:
libminiupnpc10 1.9.20140610-2ubuntu2.16.04.1
Ubuntu 14.04 LTS:
libminiupnpc8 1.6-3ubuntu2.14.04.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2017-8798