USN-3285-1: LightDM vulnerability

Ubuntu Security Notice USN-3285-1

11th May, 2017

lightdm vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 17.04
  • Ubuntu 16.10

Summary

LightDM could allow unintended access to files.

Software description

  • lightdm - Display Manager

Details

Tyler Hicks discovered that LightDM did not confine the user session for guest
users. An attacker with physical access could use this issue to access files
and other resources that they should not be able to access. In the default
installation, this includes files in the home directories of other users on the
system. This update fixes the issue by disabling the guest session. It may be
re-enabled in a future update. Please see the bug referenced below for
instructions on how to manually re-enable the guest session.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 17.04:
lightdm 1.22.0-0ubuntu2.1
Ubuntu 16.10:
lightdm 1.19.5-0ubuntu1.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make
all the necessary changes.

References

CVE-2017-8900, LP: 1663157