USN-3215-2: Munin regression

Ubuntu Security Notice USN-3215-2

3rd March, 2017

munin regression

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 LTS

Summary

USN-3215-1 introduced a regression in Munin.

Software description

  • munin - Network-wide graphing framework

Details

USN-3215-1 fixed a vulnerability in Munin. The upstream patch caused a
regression leading to errors being appended to the log file. This update
fixes the problem.

Original advisory details:

It was discovered that Munin incorrectly handled CGI graphs. A remote
attacker could use this issue to overwrite arbitrary files as the www-data
user.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 14.04 LTS:
munin 2.0.19-3ubuntu0.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

LP: 1669764