USN-3012-1: Wget vulnerability

Ubuntu Security Notice USN-3012-1

20th June, 2016

wget vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 16.04 LTS
  • Ubuntu 15.10
  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS

Summary

Wget could be made to overwrite files.

Software description

  • wget - retrieves files from the web

Details

Dawid Golunski discovered that Wget incorrectly handled filenames when
being redirected from an HTTP to an FTP URL. A malicious server could
possibly use this issue to overwrite local files.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 16.04 LTS:
wget 1.17.1-1ubuntu1.1
Ubuntu 15.10:
wget 1.16.1-1ubuntu1.1
Ubuntu 14.04 LTS:
wget 1.15-1ubuntu1.14.04.2
Ubuntu 12.04 LTS:
wget 1.13.4-2ubuntu1.4

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2016-4971