USN-698-1: Nagios vulnerability

Ubuntu Security Notice USN-698-1

22nd December, 2008

nagios vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.06 LTS

Software description

  • nagios

Details

It was discovered that Nagios did not properly parse commands submitted using
the web interface. An authenticated user could use a custom form or a browser
addon to bypass security restrictions and submit unauthorized commands.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 6.06 LTS:
nagios-common 2:1.3-cvs.20050402-8ubuntu8

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart Nagios to effect
the necessary changes.

References

CVE-2008-5027