USN-2836-1: GRUB vulnerability

Ubuntu Security Notice USN-2836-1

15th December, 2015

grub2 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 15.10
  • Ubuntu 15.04
  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS

Summary

GRUB password protection can be bypassed.

Software description

  • grub2 - GRand Unified Bootloader

Details

Hector Marco and Ismael Ripoll discovered that GRUB incorrectly handled
the backspace key when configured to use authentication. A local attacker
could use this issue to bypass GRUB password protection.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 15.10:
grub2-common 2.02~beta2-29ubuntu0.2
Ubuntu 15.04:
grub2-common 2.02~beta2-22ubuntu1.4
Ubuntu 14.04 LTS:
grub2-common 2.02~beta2-9ubuntu1.6
Ubuntu 12.04 LTS:
grub2-common 1.99-21ubuntu3.19

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make
all the necessary changes.

References

CVE-2015-8370