USN-764-1: Firefox and Xulrunner vulnerabilities

Ubuntu Security Notice USN-764-1

22nd April, 2009

firefox-3.0, xulrunner-1.9 vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS

Software description

  • firefox-3.0
  • xulrunner-1.9

Details

Several flaws were discovered in the browser engine. If a user were tricked
into viewing a malicious website, a remote attacker could cause a denial of
service or possibly execute arbitrary code with the privileges of the user
invoking the program. (CVE-2009-1302, CVE-2009-1303, CVE-2009-1304,
CVE-2009-1305)

It was discovered that Firefox displayed certain Unicode characters which
could be visually confused with punctuation in valid web addresses in the
location bar. An attacker could exploit this to spoof the location bar,
such as in a phishing attack. (CVE-2009-0652)

Several flaws were discovered in the way Firefox processed malformed URI
schemes. If a user were tricked into viewing a malicious website, a remote
attacker could execute arbitrary JavaScript or steal private data.
(CVE-2009-1306, CVE-2009-1307, CVE-2009-1309, CVE-2009-1310, CVE-2009-1312)

Cefn Hoile discovered Firefox did not adequately protect against embedded
third-party stylesheets. An attacker could exploit this to perform script
injection attacks using XBL bindings. (CVE-2009-1308)

Paolo Amadini discovered that Firefox would submit POST data when reloading
an inner frame of a web page. If a user were tricked into viewing a
malicious website, a remote attacker could steal private data.
(CVE-2009-1311)

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 9.04:
firefox-3.0 3.0.9+nobinonly-0ubuntu0.9.04.1
abrowser 3.0.9+nobinonly-0ubuntu0.9.04.1
xulrunner-1.9 1.9.0.9+nobinonly-0ubuntu0.9.04.1
Ubuntu 8.10:
firefox-3.0 3.0.9+nobinonly-0ubuntu0.8.10.1
abrowser 3.0.9+nobinonly-0ubuntu0.8.10.1
xulrunner-1.9 1.9.0.9+nobinonly-0ubuntu0.8.10.1
Ubuntu 8.04 LTS:
firefox-3.0 3.0.9+nobinonly-0ubuntu0.8.04.1
xulrunner-1.9 1.9.0.9+nobinonly-0ubuntu0.8.04.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart Firefox and any
applications that use xulrunner, such as Epiphany, to effect the necessary
changes.

References

CVE-2009-0652, CVE-2009-1302, CVE-2009-1303, CVE-2009-1304, CVE-2009-1305, CVE-2009-1306, CVE-2009-1307, CVE-2009-1308, CVE-2009-1309, CVE-2009-1310, CVE-2009-1311, CVE-2009-1312