USN-705-1: NTP vulnerability

Ubuntu Security Notice USN-705-1

8th January, 2009

ntp vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 7.10
  • Ubuntu 6.06 LTS

Software description

  • ntp

Details

It was discovered that NTP did not properly perform signature verification.
A remote attacker could exploit this to bypass certificate validation via
a malformed SSL/TLS signature.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 8.10:
ntp 1:4.2.4p4+dfsg-6ubuntu2.2
Ubuntu 8.04 LTS:
ntp 1:4.2.4p4+dfsg-3ubuntu2.1
Ubuntu 7.10:
ntp 1:4.2.4p0+dfsg-1ubuntu2.1
Ubuntu 6.06 LTS:
ntp-simple 1:4.2.0a+stable-8.1ubuntu6.1
ntp-refclock 1:4.2.0a+stable-8.1ubuntu6.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

CVE-2009-0021