USN-686-1: AWStats vulnerability

Ubuntu Security Notice USN-686-1

3rd December, 2008

awstats vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 7.10
  • Ubuntu 6.06 LTS

Software description

  • awstats

Details

Morgan Todd discovered that AWStats did not correctly strip quotes from
certain parameters, allowing for an XSS attack when running as a CGI.
If a user was tricked by a remote attacker into following a specially
crafted URL, the user's authentication information could be exposed for
the domain where AWStats was hosted.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 8.10:
awstats 6.7.dfsg-5ubuntu0.1
Ubuntu 8.04 LTS:
awstats 6.7.dfsg-1ubuntu0.1
Ubuntu 7.10:
awstats 6.6+dfsg-1ubuntu0.1
Ubuntu 6.06 LTS:
awstats 6.5-1ubuntu1.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

CVE-2008-3714, CVE-2008-5080