USN-677-1: vulnerabilities

Ubuntu Security Notice USN-677-1

25th November, 2008, vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 7.10
  • Ubuntu 6.06 LTS

Software description



Multiple memory overflow flaws were discovered in's handling of
WMF and EMF files. If a user were tricked into opening a specially crafted
document, a remote attacker might be able to execute arbitrary code with user
privileges. (CVE-2008-2237, CVE-2008-2238)

Dmitry E. Oboukhov discovered that senddoc, as included in,
created temporary files in an insecure way. Local users could exploit a race
condition to create or overwrite files with the privileges of the user invoking
the program. This issue only affected Ubuntu 8.04 LTS. (CVE-2008-4937)

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 8.10: 1:2.4.1-11ubuntu2.1
Ubuntu 8.04 LTS: 1:2.4.1-1ubuntu2.1 1:2.4.1-1ubuntu2.1
Ubuntu 7.10: 1:2.3.0-1ubuntu5.5
Ubuntu 6.06 LTS: 2.0.2-2ubuntu12.7-2

To update your system, please follow these instructions:

After a standard system upgrade you need to restart to effect
the necessary changes.


CVE-2008-2237, CVE-2008-2238, CVE-2008-4937