Ubuntu Security Notice USN-612-1
13th May, 2008
A security issue affects these releases of Ubuntu and its derivatives:
- Ubuntu 8.04 LTS
- Ubuntu 7.10
- Ubuntu 7.04
A weakness has been discovered in the random number generator used
by OpenSSL on Debian and Ubuntu systems. As a result of this
weakness, certain encryption keys are much more common than they
should be, such that an attacker could guess the key through a
brute-force attack given minimal knowledge of the system. This
particularly affects the use of encryption keys in OpenSSH, OpenVPN
and SSL certificates.
This vulnerability only affects operating systems which (like
Ubuntu) are based on Debian. However, other systems can be
indirectly affected if weak keys are imported into them.
We consider this an extremely serious vulnerability, and urge all
users to act immediately to secure their systems. (CVE-2008-0166)
== Who is affected ==
Systems which are running any of the following releases:
* Ubuntu 7.04 (Feisty)
* Ubuntu 7.10 (Gutsy)
* Ubuntu 8.04 LTS (Hardy)
* Ubuntu "Intrepid Ibex" (development): libssl <= 0.9.8g-8
* Debian 4.0 (etch) (see corresponding Debian security advisory)
and have openssh-server installed or have been used to create an
OpenSSH key or X.509 (SSL) certificate.
All OpenSSH and X.509 keys generated on such systems must be
considered untrustworthy, regardless of the system on which they
are used, even after the update has been applied.
This includes the automatically generated host keys used by OpenSSH,
which are the basis for its server spoofing and man-in-the-middle
The problem can be corrected by updating your system to the following package version:
- Ubuntu 8.04 LTS:
- libssl0.9.8 0.9.8g-4ubuntu3.1
- Ubuntu 7.10:
- libssl0.9.8 0.9.8e-5ubuntu3.2
- Ubuntu 7.04:
- libssl0.9.8 0.9.8c-4ubuntu0.3
To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.
In general, a standard system upgrade is sufficient to effect the