USN-570-1: boost vulnerabilities

Ubuntu Security Notice USN-570-1

16th January, 2008

boost vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.10
  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software description

  • boost

Details

Will Drewry and Tavis Ormandy discovered that the boost library
did not properly perform input validation on regular expressions.
An attacker could send a specially crafted regular expression to
an application linked against boost and cause a denial of service
via application crash.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 7.10:
libboost-regex1.34.1 1.34.1-2ubuntu1.1
Ubuntu 7.04:
libboost-regex1.33.1 1.33.1-9ubuntu3.1
Ubuntu 6.10:
libboost-regex1.33.1 1.33.1-7ubuntu1.1
Ubuntu 6.06 LTS:
libboost-regex1.33.1 1.33.1-2ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

CVE-2008-0171, CVE-2008-0172