USN-480-1: Gimp vulnerability

Ubuntu Security Notice USN-480-1

4th July, 2007

gimp vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Details

Stefan Cornelius discovered that Gimp could miscalculate the size of heap
buffers when processing PSD images. By tricking a user into opening a
specially crafted PSD file with Gimp, an attacker could exploit this to
execute arbitrary code with the user's privileges.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 7.04:
gimp 2.2.13-1ubuntu4.2
Ubuntu 6.10:
gimp 2.2.13-1ubuntu3.2
Ubuntu 6.06 LTS:
gimp 2.2.11-1ubuntu3.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

CVE-2007-2949