USN-467-1: Gimp vulnerability

Ubuntu Security Notice USN-467-1

31st May, 2007

gimp vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Details

It was discovered that Gimp did not correctly handle RAS image format
color tables. By tricking a user into opening a specially crafted RAS
file with Gimp, an attacker could exploit this to execute arbitrary code
with the user's privileges.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 7.04:
gimp 2.2.13-1ubuntu4.1
Ubuntu 6.10:
gimp 2.2.13-1ubuntu3.1
Ubuntu 6.06 LTS:
gimp 2.2.11-1ubuntu3.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

CVE-2007-2356