USN-459-1: pptpd vulnerability

Ubuntu Security Notice USN-459-1

14th May, 2007

pptpd vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Details

A flaw was discovered in the PPTP tunnel server. Remote attackers could
send a specially crafted packet and disrupt established PPTP tunnels,
leading to a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 7.04:
pptpd 1.3.0-2ubuntu2.1
Ubuntu 6.10:
pptpd 1.3.0-1ubuntu1.1
Ubuntu 6.06 LTS:
pptpd 1.2.3-1ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

CVE-2007-0244