USN-447-1: KDE library vulnerabilities

Ubuntu Security Notice USN-447-1

28th March, 2007

kdelibs vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.10
  • Ubuntu 6.06 LTS
  • Ubuntu 5.10

Details

It was discovered that Konqueror did not correctly handle iframes from
JavaScript. If a user were tricked into visiting a malicious website,
Konqueror could crash, resulting in a denial of service. (CVE-2007-1308)

A flaw was discovered in how Konqueror handled PASV FTP responses. If a
user were tricked into visiting a malicious FTP server, a remote
attacker could perform a port-scan of machines within the user's
network, leading to private information disclosure. (CVE-2007-1564)

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 6.10:
kdelibs4c2a 4:3.5.5-0ubuntu3.1.1
Ubuntu 6.06 LTS:
kdelibs4c2a 4:3.5.2-0ubuntu18.3
Ubuntu 5.10:
kdelibs4c2 4:3.4.3-0ubuntu2.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart your session or
reboot your computer to effect the necessary changes.

References

CVE-2007-1308, CVE-2007-1564