USN-444-1: OpenOffice.org vulnerabilities

Ubuntu Security Notice USN-444-1

27th March, 2007

openoffice.org(2)/-amd64, ia32-libs-openoffice.org vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.10
  • Ubuntu 6.06 LTS
  • Ubuntu 5.10

Details

A stack overflow was discovered in OpenOffice.org's StarCalc parser. If
a user were tricked into opening a specially crafted document, a remote
attacker could execute arbitrary code with user privileges.
(CVE-2007-0238)

A flaw was discovered in OpenOffice.org's link handling code. If a user
were tricked into clicking a link in a specially crafted document, a
remote attacker could execute arbitrary shell commands with user
privileges. (CVE-2007-0239)

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 6.10:
openoffice.org-calc 2.0.4-0ubuntu5
openoffice.org-core 2.0.4-0ubuntu5
Ubuntu 6.06 LTS:
openoffice.org2-base 2.0.2-2ubuntu12.3
openoffice.org-calc 2.0.2-2ubuntu12.3
ia32-libs-openoffice.org 11.0.2
openoffice.org2-calc 2.0.2-2ubuntu12.3
openoffice.org-core 2.0.2-2ubuntu12.3
Ubuntu 5.10:
openoffice.org2-core 1.9.129-0.1ubuntu4.3-1
openoffice.org2-calc 1.9.129-0.1ubuntu4.3-1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart OpenOffice, or
reboot your computer to effect the necessary changes.

References

CVE-2007-0238, CVE-2007-0239