USN-439-1: file vulnerability

Ubuntu Security Notice USN-439-1

21st March, 2007

file vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.10
  • Ubuntu 6.06 LTS
  • Ubuntu 5.10

Details

Jean-Sebastien Guay-Leroux discovered that "file" did not correctly
check the size of allocated heap memory. If a user were tricked into
examining a specially crafted file with the "file" utility, a remote
attacker could execute arbitrary code with user privileges.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 6.10:
libmagic1 4.17-2ubuntu1.1
Ubuntu 6.06 LTS:
libmagic1 4.16-0ubuntu3.1
Ubuntu 5.10:
libmagic1 4.12-1ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

CVE-2007-1536