USN-430-1: mod_python vulnerability

Ubuntu Security Notice USN-430-1

6th March, 2007

libapache2-mod-python vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.06 LTS
  • Ubuntu 5.10

Details

Miles Egan discovered that mod_python, when used in output filter mode,
did not handle output larger than 16384 bytes, and would display freed
memory, possibly disclosing private data. Thanks to Jim Garrison of the
Software Freedom Law Center for identifying the original bug as a
security vulnerability.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 6.06 LTS:
libapache2-mod-python 3.1.4-0ubuntu1.1
Ubuntu 5.10:
libapache2-mod-python 3.1.3-3ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart Apache to effect the
necessary changes.

References

CVE-2004-2680