USN-410-1: poppler vulnerability

Ubuntu Security Notice USN-410-1

18th January, 2007

kdegraphics, koffice, poppler vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.10
  • Ubuntu 6.06 LTS
  • Ubuntu 5.10

Details

The poppler PDF loader library did not limit the recursion depth of
the page model tree. By tricking a user into opening a specially
crafter PDF file, this could be exploited to trigger an infinite loop
and eventually crash an application that uses this library.

kpdf in Ubuntu 5.10, and KOffice in all Ubuntu releases contains a
copy of this code and thus is affected as well.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 6.10:
libpoppler1 0.5.4-0ubuntu4.1
kword 1:1.5.2-0ubuntu2.1
Ubuntu 6.06 LTS:
libpoppler1 0.5.1-0ubuntu7.1
kword 1:1.5.0-0ubuntu9.1
Ubuntu 5.10:
kpdf 4:3.4.3-0ubuntu2.6
kword 1:1.4.1-0ubuntu7.5
libpoppler0c2 0.4.2-0ubuntu6.8

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

CVE-2007-0104