USN-389-1: GnuPG vulnerability

Ubuntu Security Notice USN-389-1

29th November, 2006

gnupg vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.10
  • Ubuntu 6.06 LTS
  • Ubuntu 5.10

Details

A buffer overflow was discovered in GnuPG. By tricking a user into
running gpg interactively on a specially crafted message, an attacker
could execute arbitrary code with the user's privileges. This
vulnerability is not exposed when running gpg in batch mode.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 6.10:
gnupg 1.4.3-2ubuntu3.1
Ubuntu 6.06 LTS:
gnupg 1.4.2.2-1ubuntu2.3
Ubuntu 5.10:
gnupg 1.4.1-1ubuntu1.5

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

http://lists.gnupg.org/pipermail/gnupg-announce/2006q4/000241.html