USN-380-2: avahi regression

Ubuntu Security Notice USN-380-2

14th December, 2006

avahi regression

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.10
  • Ubuntu 6.06 LTS
  • Ubuntu 5.10

Details

USN-380-1 fixed a vulnerability in Avahi. However, if used with
Network manager, that version occasionally failed to resolve .local
DNS names until Avahi got restarted. This update fixes the problem.

We apologize for the inconvenience.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 6.10:
avahi-daemon 0.6.13-2ubuntu2.3
Ubuntu 6.06 LTS:
avahi-daemon 0.6.10-0ubuntu3.3
Ubuntu 5.10:
avahi-daemon 0.5.2-1ubuntu1.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

LP: 72728