USN-367-1: Pike vulnerability

Ubuntu Security Notice USN-367-1

18th October, 2006

pike7.6 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 5.04


An SQL injection was discovered in Pike's PostgreSQL module.
Applications using a PostgreSQL database and uncommon character
encodings could be fooled into running arbitrary SQL commands, which
could result in privilege escalation within the application, application
data exposure, or denial of service.

Please refer to for more detailled

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 5.04:
pike7.6-pg 7.6.13-1ubuntu0.1

To update your system, please follow these instructions:

In general, a standard system upgrade is sufficient to effect the
necessary changes.