USN-2301-1: Jinja2 vulnerabilities

Ubuntu Security Notice USN-2301-1

24th July, 2014

jinja2 vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.04 LTS

Summary

A security issue was fixed in Jinja2.

Software description

  • jinja2 - small but fast and easy to use stand-alone template engine

Details

It was discovered that Jinja2 incorrectly handled temporary cache files and
directories. A local attacker could use this issue to possibly gain
privileges.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 12.04 LTS:
python-jinja2 2.6-1ubuntu0.1
python3-jinja2 2.6-1ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2014-0012, CVE-2014-1402