USN-227-1: xpdf vulnerabilities

Ubuntu Security Notice USN-227-1

12th December, 2005

xpdf/cupsys/tetex-bin/kdegraphics/koffice vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 5.10
  • Ubuntu 5.04
  • Ubuntu 4.10

Details

infamous41md discovered several integer overflows in the XPDF code,
which is present in xpdf, the Poppler library, tetex-bin, KOffice, and
kpdf. By tricking an user into opening a specially crafted PDF file,
an attacker could exploit this to execute arbitrary code with the
privileges of the application that processes the document.

The CUPS printing system also uses XPDF code to convert PDF files to
PostScript. By attempting to print such a crafted PDF file, a remote
attacker could execute arbitrary code with the privileges of the
printer server (user 'cupsys').

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 5.10:
tetex-bin
xpdf-utils
xpdf-reader
kpdf
libpoppler0c2
cupsys
kword
cupsys-client
cupsys-bsd
Ubuntu 5.04:
tetex-bin
xpdf-utils
xpdf-reader
kpdf
libpoppler0c2
cupsys
kword
cupsys-client
cupsys-bsd
Ubuntu 4.10:
tetex-bin
xpdf-utils
xpdf-reader
kpdf
libpoppler0c2
cupsys
kword
cupsys-client
cupsys-bsd

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

None

References

CVE-2005-3191, CVE-2005-3192, CVE-2005-3193