USN-2230-1: chkrootkit vulnerability

Ubuntu Security Notice USN-2230-1

4th June, 2014

chkrootkit vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 LTS
  • Ubuntu 13.10
  • Ubuntu 12.04 LTS
  • Ubuntu 10.04 LTS

Summary

chkrootkit could be made to run programs as an administrator.

Software description

  • chkrootkit - rootkit detector

Details

Thomas Stangner discovered that chkrootkit incorrectly quoted certain
values. A local attacker could use this issue to execute arbitrary code
when chkrootkit is run and gain root privileges.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 14.04 LTS:
chkrootkit 0.49-4.1ubuntu1.14.04.1
Ubuntu 13.10:
chkrootkit 0.49-4.1ubuntu1.13.10.1
Ubuntu 12.04 LTS:
chkrootkit 0.49-4ubuntu1.1
Ubuntu 10.04 LTS:
chkrootkit 0.49-3ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2014-0476