USN-2229-1: GnuTLS vulnerability

Ubuntu Security Notice USN-2229-1

2nd June, 2014

gnutls26 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 LTS
  • Ubuntu 13.10
  • Ubuntu 12.04 LTS
  • Ubuntu 10.04 LTS

Summary

GnuTLS could be made to crash or run programs if it connected to a malicious server.

Software description

  • gnutls26 - GNU TLS library

Details

Joonas Kuorilehto discovered that GnuTLS incorrectly handled Server Hello
messages. A malicious remote server or a man in the middle could use this
issue to cause GnuTLS to crash, resulting in a denial of service, or
possibly execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 14.04 LTS:
libgnutls26 2.12.23-12ubuntu2.1
Ubuntu 13.10:
libgnutls26 2.12.23-1ubuntu4.3
Ubuntu 12.04 LTS:
libgnutls26 2.12.14-5ubuntu3.8
Ubuntu 10.04 LTS:
libgnutls26 2.8.5-2ubuntu0.6

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2014-3466