USN-2218-1: Xalan-Java vulnerability

Ubuntu Security Notice USN-2218-1

21st May, 2014

libxalan2-java vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.10
  • Ubuntu 12.04 LTS
  • Ubuntu 10.04 LTS

Summary

Xalan-Java could be made to load arbitrary classes or access external resources.

Software description

  • libxalan2-java - XSL Transformations (XSLT) processor in Java

Details

Nicolas Gregoire discovered that Xalan-Java incorrectly handled certain
properties when the secure processing feature was enabled. An attacker
could possibly use this issue to load arbitrary classes or access external
resources.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 13.10:
libxsltc-java 2.7.1-8ubuntu0.1
libxalan2-java 2.7.1-8ubuntu0.1
Ubuntu 12.04 LTS:
libxsltc-java 2.7.1-7ubuntu0.1
libxalan2-java 2.7.1-7ubuntu0.1
Ubuntu 10.04 LTS:
libxalan2-java 2.7.1-5ubuntu1.1
libxalan2-java-gcj 2.7.1-5ubuntu1.1
libxsltc-java-gcj 2.7.1-5ubuntu1.1
libxsltc-java 2.7.1-5ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make all
the necessary changes.

References

CVE-2014-0107