USN-2216-1: Pidgin vulnerability

Ubuntu Security Notice USN-2216-1

21st May, 2014

pidgin vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 LTS
  • Ubuntu 13.10
  • Ubuntu 12.04 LTS

Summary

Pidgin could be made to crash or run programs if it received specially crafted network traffic.

Software description

  • pidgin - graphical multi-protocol instant messaging client for X

Details

It was discovered that Pidgin incorrectly handled certain messages from
Gadu-Gadu file relay servers. A malicious remote server or a man in the
middle could use this issue to cause Pidgin to crash, resulting in a denial
of service, or possibly execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 14.04 LTS:
pidgin 1:2.10.9-0ubuntu3.1
libpurple0 1:2.10.9-0ubuntu3.1
Ubuntu 13.10:
pidgin 1:2.10.7-0ubuntu4.1.13.10.2
libpurple0 1:2.10.7-0ubuntu4.1.13.10.2
Ubuntu 12.04 LTS:
pidgin 1:2.10.3-0ubuntu1.5
libpurple0 1:2.10.3-0ubuntu1.5

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart Pidgin to make all the
necessary changes.

References

CVE-2014-3775