USN-2209-1: libvirt vulnerabilities

Ubuntu Security Notice USN-2209-1

7th May, 2014

libvirt vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.10

Summary

Several security issues were fixed in libvirt.

Software description

  • libvirt - Libvirt virtualization toolkit

Details

It was discovered that libvirt incorrectly handled symlinks when using the
LXC driver. An attacker could possibly use this issue to delete host
devices, create arbitrary nodes, and shutdown or power off the host.
(CVE-2013-6456)

Marian Krcmarik discovered that libvirt incorrectly handled seamless SPICE
migrations. An attacker could possibly use this issue to cause a denial of
service. (CVE-2013-7336)

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 13.10:
libvirt0 1.1.1-0ubuntu8.11
libvirt-bin 1.1.1-0ubuntu8.11

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make all
the necessary changes.

References

CVE-2013-6456, CVE-2013-7336