USN-2207-1: OpenStack Swift vulnerability

Ubuntu Security Notice USN-2207-1

6th May, 2014

swift vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.10
  • Ubuntu 12.10
  • Ubuntu 12.04 LTS

Summary

OpenStack Swift would allow unintended access to files over the network.

Software description

  • swift - OpenStack distributed virtual object store

Details

Samuel Merritt discovered a timing attack vulnerability in OpenStack Swift.
If Swift was configured to use the TempURL middleware, an attacker could
exploit this to guess valid secret URLs and obtain unintended access to
objects publicly shared with specific recipients.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 13.10:
python-swift 1.10.0-0ubuntu1.1
Ubuntu 12.10:
python-swift 1.7.4-0ubuntu2.4
Ubuntu 12.04 LTS:
python-swift 1.4.8-0ubuntu2.4

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2014-0006