USN-2160-1: LibYAML vulnerability

Ubuntu Security Notice USN-2160-1

3rd April, 2014

libyaml vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.10
  • Ubuntu 12.10
  • Ubuntu 12.04 LTS

Summary

LibYAML could be made to crash or run programs if it opened a specially crafted YAML document.

Software description

  • libyaml - Fast YAML 1.1 parser and emitter library

Details

Ivan Fratric discovered that LibYAML incorrectly handled certain malformed
YAML documents. An attacker could use this issue to cause LibYAML to crash,
resulting in a denial of service, or possibly execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 13.10:
libyaml-0-2 0.1.4-2ubuntu0.13.10.3
Ubuntu 12.10:
libyaml-0-2 0.1.4-2ubuntu0.12.10.3
Ubuntu 12.04 LTS:
libyaml-0-2 0.1.4-2ubuntu0.12.04.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart applications using
LibYAML to make all the necessary changes.

References

CVE-2014-2525