USN-2156-1: Samba vulnerability

Ubuntu Security Notice USN-2156-1

26th March, 2014

samba vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.10
  • Ubuntu 12.10
  • Ubuntu 12.04 LTS
  • Ubuntu 10.04 LTS

Summary

Samba did not properly enforce the password guessing protection mechanism.

Software description

  • samba - SMB/CIFS file, print, and login server for Unix

Details

Andrew Bartlett discovered that Samba did not properly enforce the
password guessing protection mechanism for all interfaces. A remote
attacker could use this issue to possibly attempt to brute force user
passwords.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 13.10:
samba 2:3.6.18-1ubuntu3.2
Ubuntu 12.10:
samba 2:3.6.6-3ubuntu5.4
Ubuntu 12.04 LTS:
samba 2:3.6.3-2ubuntu2.10
Ubuntu 10.04 LTS:
samba 2:3.4.7~dfsg-1ubuntu3.14

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2013-4496