USN-2147-1: Mutt vulnerability

Ubuntu Security Notice USN-2147-1

13th March, 2014

mutt vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.10
  • Ubuntu 12.10
  • Ubuntu 12.04 LTS
  • Ubuntu 10.04 LTS

Summary

The mutt mail client could be made to crash or run programs as your login if it opened a specially crafted email.

Software description

  • mutt - text-based mailreader supporting MIME, GPG, PGP and threading

Details

Beatrice Torracca and Evgeni Golov discovered a buffer overflow
in mutt while expanding addresses when parsing email headers. An
attacker could specially craft an email to cause mutt to crash,
resulting in a denial of service, or possibly execute arbitrary code
with the privileges of the user invoking mutt.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 13.10:
mutt-patched 1.5.21-6.4ubuntu1.1
mutt 1.5.21-6.4ubuntu1.1
Ubuntu 12.10:
mutt-patched 1.5.21-6ubuntu0.1
mutt 1.5.21-6ubuntu0.1
Ubuntu 12.04 LTS:
mutt-patched 1.5.21-5ubuntu2.1
mutt 1.5.21-5ubuntu2.1
Ubuntu 10.04 LTS:
mutt-patched 1.5.20-7ubuntu1.2
mutt 1.5.20-7ubuntu1.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart mutt to make
all the necessary changes.

References

CVE-2014-0467