USN-2142-1: UDisks vulnerability

Ubuntu Security Notice USN-2142-1

10th March, 2014

udisks, udisks2 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.10
  • Ubuntu 12.10
  • Ubuntu 12.04 LTS

Summary

UDisks could be made to crash or run programs as an administrator.

Software description

  • udisks - service to access and manipulate storage devices
  • udisks2 - service to access and manipulate storage devices

Details

Florian Weimer discovered that UDisks incorrectly handled certain long path
names. A local attacker could use this issue to cause udisks to crash,
resulting in a denial of service, or possibly execute arbitrary code.
The default compiler options for affected releases should reduce the
vulnerability to a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 13.10:
udisks2 2.1.0-4ubuntu0.1
udisks 1.0.4-8ubuntu1.1
Ubuntu 12.10:
udisks2 2.0.0-1ubuntu1.1
udisks 1.0.4-6ubuntu0.1
Ubuntu 12.04 LTS:
udisks 1.0.4-5ubuntu2.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make all
the necessary changes.

References

CVE-2014-0004